Regressão no atendimento do Banco do Brasil

Posted by – 06/01/2010

Eu sempre disse que o Home Banking do Banco do Brasil era o melhor. Eu sempre achei muito concisa a apresentação, com uma página inicial personalizável com os links para o que você mais usa bem a mão. Até o pequeno probleminha que o tal do “Teclado Virtual” (em Java) representava não me afetava suficiente para mudar a minha opinião. Mais importante que tudo, funcionava perfeitamente no meu Debian.

Há alguns dias fiquei ainda mais feliz com o sistema, quando substituiram o teclado virtual por uma caixa de texto… Finalmente eu podia digitar a minha senha no bloco numérico do teclado “real”. No entanto essa felicidade acabou hoje…

Hoje tentei acessar a minha conta, como sempre faço nessa época do mês. O acesso era ainda mais importante, já que tenho de fazer uma pequena transferência para saldar uma dívida que vence hoje. Uma transferência entre contas BB resolveria o problema… Mal sabia o que me esperava…

Logo após digitar minha agência e conta recebo o aviso que não foi possível instalar o “Módulo de Segurança”, sugerindo que instalasse o Java, junto com um 0800 caso continuasse com problemas. Liguei às 15:55 e depois de 8 minutos na espera, Luciane me atende. Após as confirmações de agência, conta, etc, eis o diálogo:

BB: O Java está instalado? Eu: Sim (pensamento: obviamente).

BB: Desinstalou e instalou novamente? Eu: (p: não… não estou em Windows.) Sim (menti).

BB: Qual a versão do Internet Explorer? Eu: (p: ahh… ela pensou q eu estava no Windows) Nenhuma, eu uso Firefox.

BB: Firefox… sei… Qual a versão do Windows? XP? Eu: Não. Eu uso Linux (p: isso está ficando chato).

(longos segundos depois…) BB: O senhor precisa instalar o Java então. Eu: (p: ai meu Deus!) Eu já instalei o Java! Tenho a versão 1.6.0.15!

(longos segundos depois…) BB: Mas a última versão é a 1.6.0.17… o senhor precisa atualizar. Como o senhor usa Linux, o senhor não precisa do Módulo de Segurança… é só instalar a última versão do Java e pronto. Eu: (p: pouco provável que faça alguma diferença) Ok… Eu vou instalar o negócio… se continuar não funcionando ligo de volta.

Eu sei… eu sei. Pouco provável que uma sub-sub-sub-versão do Java faça qualquer diferença. Ainda mais considerando que essa versão foi lançada no finalzinho de 2009! E que papo é esse de que “Não preciso do Módulo de Segurança”? Mas, vamos lá…

Muito bem… instalada a versão que o BB quer… Vamos a ligação. Agora são 16:42… fico na espera por mais 9 minutos e sou atendido pela mesma Luciane (espantosamente). Verificações de rotina, dou o número do protocolo de atendimento anterior e eis o curto diálogo:

Eu: Bem, atualizei o Java conforme foi solicitado, mas persiste o mesmo erro. BB: Senhor Pablo, eu vou abrir o chamado para o segundo nível entrar em contato com o senhor por que não temos mais procedimentos.

Eu: E quando eles estrarão em contato? BB: Não sei lhe informar já que é outro setor.

Bem… Longos minutos depois ela me pergunta tudo de novo (qual versão disso, qual versão daquilo, blá, blá, blá), me dá um novo número de protocolo e reafirma que o “segundo nível” vai entrar em contato comigo.

Resultado: não paguei a dívida e resolvi blogar a respeito na esperança que o credor se compadeça de mim e perdoe os juros… Enquanto isso não consigo acessar a minha conta, algo que há apenas 10 dias tinha realizado com sucesso, sem atualizar ou instalar nada.

Pra aderir ao Twitt-speech: BB #FAIL!

Eu volto a blogar sobre isso, se (1) encontrar uma solução independentemente; (2) Voltar a funcionar espontâneamente; (3) Na improvável hipótese de ser contatado por um “segundo nível”. Enquanto isso, se alguém souber a solução, comenta aí!

10 Comments on Regressão no atendimento do Banco do Brasil

  1. spectra says:

    @Sergio,

    Realmente. Ainda não recebi nenhum retorno do “segundo nível”. Lá se vão 22 dias!

  2. spectra says:

    @ALL,

    Realmente, parece que os problemas estão restritos a arquitetura 64bits, com qualquer versao de Java. Em 32bits, está funcionando…

    @Marcelo,

    Testei o seu workaround em 64bits, e nada… Realmente parece algo relacionado a arquitetura.

  3. spectra says:

    @Marcelo,

    Obrigado pela informação, vou testar assim que chegar na minha máquina. No entanto, de antemão parece seu bug não está relacionado… Como eu disse, estava usando uma versão antiga do Java e funcionava perfeitamente apenas 10 dias antes dos erros. Ele parou de funcionar ainda com aquela versão! Eu só atualizei pq o banco pediu e o erro persistia…

    Como eu disse, vou testar. Mas parece q seu bug não está relacionado. Reporto em seguida.

  4. spectra says:

    @ALL,

    Testei em ambas arquiteturas… realmente o problema acontece em ambas. No amd64 nunca consegui fazer funcionar. No ia32 ele funciona esporadicamente… Estou começando a pensar que pode ser um problema de certificado. Achei muito estranho, em um dos meus acessos bem sucedidos, que o certificado expirasse minutos depois do momento em que estava acessando…

  5. spectra says:

    @Augusto,

    Parece que o certificado expirava ontem mesmo… Vou verificar isso.

    @Sergio,

    Hm… eu estava usando um amd64… Vou ver se isso ocorre em outra arquitetura e reporto para vcs.

  6. Ivan says:

    22 dias porque provavelmente eles não têm solução, eu acabo de abrir meu chamado para atendimento do segundo nível. Aqui ubuntu 9.10 amd64…

  7. Sergio says:

    Pois é, até agora nada de solução por parte do BB.
    Criei uma maquina virtual de 32 bits com o Karmic Koala só pra poder acessar minha conta. Triste mas, pelo menos tá funciona.

  8. Marcelo says:

    Olá Pablo,

    Eu reportei o bug com referência ao sun-java6-plugin no dia 19/12/09, e pelo que notei, diversas pessoas tiveram o mesmo problema.

    Pelo que parece, estranhamente, tratasse de um problema do java com ipv6. Como recentemente o net-base do Debian squeeze o passou a adotar “net.ipv6.bindv6only=1” como padrão, diversas aplicações web feitas em java deixaram de funcionar, simplesmente por não detectarem a presença no java na máquina cliente.

    Por hora, a solução provisória para tal problema é alterar o valor da diretiva “net.ipv6.bindv6only= ” para “0” no arquivo /etc/sysctl.d/bindv6only.conf, e posteriormente reiniciar o procfs.

    Logicamente a falha com o ipv6 continua, inclusive com relatos mais específicos a respeito 1. Espero que logo seja resolvido de fato.

    Um abraço,
    Marcelo (aka darkstar)

  9. Sergio says:

    Eu estou com problemas pra acessar o BB também. Tudo funciona bem no Ubuntu 9.10 de 32 bits, mas não no de 64 bits.
    Tenho um chamado aberto desde o dia 28/12, mas, até agora, nada….

  10. Acessei agora à noite, com Firefox e Ubuntu, e a autenticação/autorização funcionou como de hábito, embora tenha acontecido algo incomum: depois de eu já estar no sistema do banco, apareceu uma janela feiosa informando que um certificado estava expirado.

    Talvez os problemas (o que tu viu durante o expediente, e este que eu vi de noite) estejam relacionados entre si…

Leave a Reply

Your email address will not be published. Required fields are marked *